Routing information protocol version 1,2

Чөлөөт нэвтэрхий толь — Википедиагаас
Jump to navigation Jump to search

Version[засварлах | edit source]

Routing information protocol version 1[засварлах | edit source]

Rip-ийн тухай[засварлах | edit source]

Энэхүү замчлалын протокол нь Distance Vector Routing Protocol – ийн хамгийн эхэн үеийн протокол юм. Зураг 1.1-ээс замчлалын протоколуудыг харна уу

RIP нь анх XEROX – оос хөгжүүлэгдэж ирсэн бөгөөд эхэндээ Gateway information Protocol гэдэг нэртэй байжээ. Charles Hedrick стандартыг нь 1988 онд боловсруулан гаргасан бөгөөд энэ нь RIPv1 буюу RFC1058-аар тодорхойлогддог.

RIP-ийн шинж чанар:
  1. classful, Distance Vector (DV) төрлийн протокол
  2. periodic update-Энэ нь тогтмол хугацаанд рутерууд нь замчлалын тухай мэдээллээ хоорондоо солилцож, замчлалын хүснэгтээ шинэчилж байдаг.
  3. Сүлжээний бүтэц өөрчлөгдөхөд илгээгдэхгүй.Update мэдээ нь broadcast 30 секунд тутамд дамждаг.
  4. Triggered updates-Энэ update замчлал өөрчлөгдөхөд илгээгддэг. Тогтмол хугацааны шинэчлэлтийг хүлээлгүйгээр шууд дамжуулагдана.Хүлээн авсан рутерууд нь мөн triggered шинэчлэлийг үүсгэн хажуу рутерууд рүүгээ дамжуулдаг.RIP протокол ашигладаг.Triggered update илгээгдэх тохиолдлууд нь:Интерфейсийн төлвийн өөрчлөлт (up болон down),Шинэ холболт нэмэгдэх болон хасагдах,Шинэ замчлалын мэдээлэл замчлалын хүснэгтэд бүртгэгдэх
  5. Метрик =Зөвхөн хопыг тоолдог бөгөөд түүгээрээ замчлалыг сонгодог.Хопыг тоолоод 15 дээш болбол тухайн сүлжээг unreachable буюу дамжуулалт байхгүй гэж үздэг
  6. Administrative Distance-rip AD нь default-аараа 120 байдаг.
  7. Routing Loops-Статик замчлалыг алдаатай бичсэн,Замчлалын хуваарилалт алдаатай,Convergence удаанаас болж сүлжээний шинэчлэл хийгдэж чадаагүй,Замчлал хийгдээгүй нөхцлүүдээс болж үүсч болно.Routing loop-ийг арилгах дараах аргууд байна:–Count to infinity,Holddown timer,Split horizon,Route poisoning болон Poison reverse,Triggered update
  8. Rip нь UDP 520 портыг ашиглана.
  9. Automatic Route Summarization- Classful сүлжээний хувьд тасралт үүсч байгаа сүлжээний уулзвар дээр байгаа рутерыг Boundary рутер гэнэ.RIPv1 2 дүрмээр Update-г хийнэ:
  • Хэрэв тухайн интерфейсээр өөрийнх нь prefix-тэй ижил prefix бүхий сүжээний update мэдээ орж ирвэл тухайн сүлжээг хүлээж аван замчлалын хүснэгт рүү бичнэ.
  • Хэрэв тухайн интерфейсээр өөр сүлжээ буюу тасралттай сүлжээний update мэдээ гарвал тухайн сүлжээг classful range-рүү нэгтгэж гаргана.

Протоколын ашигладаг хаягууд[засварлах | edit source]

  • IP address – 255.255.255.255
  • MAC address – FF:FF:FF:FF:FF:FF

RIP мэдээлэл нь UDP сегментээр энкапсулашн хийгддэг. Хүлээн авах болон эх үүсвэрийн портын дугаар нь 520 байдаг.Сүлжээний болон data link түвшний толгойн мэдээлэлд хүлээн авах хаяг нь broadcast, эх үүсвэрийн хаяг нь мэдээллийг дамжуулж байгаа интерфейсийн хаяг байна.

Мэдээний формат[засварлах | edit source]

зураг 1.3-аас талбаруудын тайлбарыг харна уу

  • Command – Мэдээний төрлийг заана. 1 гэсэн утгатай бол хүсэлт, 2 гэсэн утгатай бол хариу
  • Version – хувилбарыг заана. 1гэсэн утгатай бол RIPv1, 2 гэсэн утгатай бол RIPv2
  • Address Family Identifier – 2 гэсэн утгатай хаяггүй бол замчлалын хүснэгтийг бүтнээр нь, талбараас сонгох бол 0 гэсэн утгатай байна.
  • IP address - хүрэх замчлалын хаяг. Үүнд сүлжээний хаяг, subnet mask, эсвэл хостын хаяг байна.
  • Metric – хопын тоо байна. 1-16 – ийн хооронд.
  • Default administrative distance нь 120 байдаг.

Ажиллагаа болон тохиргоо[засварлах | edit source]

RIP–ийн ажиллагаа:RIP нь хоѐр төрлийн мэдээг ашигладаг ба энэ нь command гэсэн талбар дээр тодорхойлогддог. RIP тохируулсан бүх интерфейсээр хөрш рутерууд руу хүсэлтийг илгээдэг. Хариуг RIP нээлттэй байгаа бүх хөршүүд буцааж илгээдэг. Хариуг аваад түүний мэдээллийг үзээд шинэ замчлалын мэдээлэл байвал өөрийн замчлалын мэдээлэлд бүртгэн авдаг.RIP нь classful замчлалын протокол тул subnet маскийн тухай мэдээллийг шинэчлэлийн мэдээнд оруулж дамжуулдаггүй.
RIP тохиргоо:Динамик замчлалын протоколуудыг идэвхжүүлэхдээ рутерийн глобаль тохиргооны горим дээр router гэсэн командыг ашигладаг. RIP – ийг тохируулахын тулд араас нь rip гэж бичиж өгдөг. Ингэснээр RIP тохиргооны горим руу шилжинэ. Дараа нь энэ горим дээр тухайн рутерт шууд холбогдсон байгаа сүлжээнүүдийн тухай мэдээллийг бичиж өгдөг.Ингэж бичихдээ network гэсэн командын тусламжтайгаар бичиж өгдөг.
Router(config-router)#network directly-connected-classful-network-address

Хэрвээ дэд сүлжээнд хуваагдсан сүлжээний хаяг бичвэл RIP нь түүнийг автоматаар Classful хаяг хөрвүүлдэг. Жишээлбэл 192.168.1.128 гэж оруулсан бол түүнийг 192.168.1.0 гэж оруулдаг.

зураг 1.4 жишээ топологи
төхөөрөмж команд
R1
     Router>en
     Router#conf t
     Router#hostname R1
     R1-н интерфейс дээр ip хаяг тохируулах
     R1(config)#int s0/0/0
     R1(config-if)#ip add 10.1.1.1 255.0.0.0
     R1(config-if)#clock rate 64000
     R1(config-if)#no shut
     R1(config-if)#int f0/0
     R1(config-if)#ip add 172.16.1.1 255.255.0.0
     R1(config-if)#no shut
     R1(config-if)#exit
     rip протокол тохируулах
     R1(config)#Router Rip
     R1(config-router)#network 10.0.0.0
     R1(config-router)#network 172.16.0.0
     R1(config-router)#exit
     R1(config)#exit
     R1#wr
R2
      Router>en
      Router#conf t
      Router(config)#hostname R2
      R2-н интерфейс дээр ip хаяг тохируулах
      R2(config)#int s0/0/1
      R2(config-if)#ip add 10.1.1.2 255.0.0.0
      R2(config-if)#no shut
      R2(config-if)#int f0/0
      R2(config-if)#ip add 192.168.1.1 255.255.255.0
      R2(config-if)#no shut
      R2(config-if)#exit
      Rip тохируулах
      R2(config)#router rip
      R2(config-router)#network 10.0.0.0
      R2(config-router)#network 192.168.1.0
      R2(config-router)#exit
      R2(config)#exit
      R2#wr
Default information originate command-Зөвхөн дифаулт замчлалыг түгээх үүрэгтэй.
Redistribute-Бүх төрлийн эх үүсвэрээс сүлжээний мэдээллийг RIP-н update-д оруулдаг.
тохиргоо:

default information originate

R2(config)#router rip
R2(config-router)#default-information originate

redistribute

R2(config)#router rip
R2(config-router)#redistribute static
R2(config-router)#network 10.0.0.0
R2(config-router)#network 209.165.200.0
Зураг 1.5 топологи
Зураг 1.6 Default замчлал тохиргоо
Зураг 1.7 Static замчлал тохиргоо

Тохиргоо болон ажиллагааг харах, шалгах[засварлах | edit source]

Замчлалын тухай мэдээллийг харах болон шалгахдаа:

  • router#show ip route //рутерийн замчлалын хүснэгтэд бичигдсэн замчлалын тухай мэдээллийг хардаг.
  • router#show ip protocols //ямар протокол ашигласан тухай мэдээллийг хардаг.
  • router#copy running-config startup-config |router#show running-config//хийсэн тохиргоогоо хадгалах
  • router#debug ip rip//rip протоколын ажиллагааг шалгах
Зураг 1.8 Routing table

Гаралтанд байгаа мэдээллийн R үсгээр тэмдэглэгдсэн бичиглэл бол RIP замчлал хийгдсэн гэдгийг зааж байдаг. Гаралтын мэдээллийг авч үзвэл:(зураг 1.8)

  • R–RIP тохиргоо хийгдсэн гэдгийг зааж байна
  • 192.168.5.0/24 – алслагдсан сүлжээний хаяг болон subnet mask
  • 120/2 – administrative distance болон хопын тоо
  • 192.168.2.2 – дараагийн хопын хаяг
  • 00:00:23 – хэдэн секундын дараа дараагийн шинэчлэлийн мэдээлэл солилцохыг заадаг.
  • Serial 0/0/0 – хүлээн авах сүлжээ холбогдсон интерфейс

Passive interface[засварлах | edit source]

Зарим интерфейсээр RIP шинэчлэлийг дамжуулах шаардлагагүй байдаг ба дамжуулснаар дараах нөлөөллүүд үүсдэг. RIP шинэчлэл нь broadcast-аар дамжуулагддаг тул сүлжээнд ачаалал үүсгэдэг. Бүх төхөөрөмжүүд мэдээллийг дамжуулалтын түвшин хүртэл хүлээн авах боловч хэрэггүй мэдээлэл тул түүнийг устгадаг. Сүлжээний аюулгүй болон найдвартай ажиллагааг бууруулдаг. Яагаад гэвэл RIP мэдээллийг дундаас нь саатуулж аваад хариу мэдээлэлд нь өөр мэдээлэл илгээж сүлжээний тухай буруу мэдээллийг өгч сүлжээний ажиллагааг өөрчилж алдаа гаргаж болзошгүй байдаг.Тиймээс шаардлагагүй интерфейсүүдийг идэвхигүй болгож болдог ба ингэхийн тулд passive-interface гэсэн командыг ашигладаг.

Router(config-router)#passive-interface interface-type interface-number /Энэхүү командыг замчлалын бүх протоколууд дэмжин ажилладаг./Зураг 1.9-оос харна уу
зураг 1.9 passive interface тохируулах болон гаралтын мэдээ

Гаралтын мэдээний тайлбар:

  1. Тухайн рутер дээр RIP тохируулагдсан ба ажиллаж байгааг харуулна.
  2. Хугацаануудын тухай мэдээллийг гаргана. Жишээлбэл 23 секундын дараа дараагийн шинэчлэл хийгдэнэ гэх мэт.
  3. Хэрвээ тохируулагдсан бол шинэчлэлийг шүүх болон замчлалын тухай мэдээллийг дахин хуваарилах тухай мэдээллийг харуулна.
  4. RIP–ийн хувилбар болон интерфейсүүдийн мэдээлэл солилцсон тухай мэдээллийг харуулна.
  5. Classful сүлжээний хязгаарыг харуулна.
  6. Тухайн рутерт network командаар бичигдсэн сүлжээнүүдийн тухай мэдээлэл харагдана. Энэ сүлжээнүүдийг RIP – ийн шинэчлэлийн мэдээлэлд оруулан дамжуулдаг.
  7. Тухайн рутерийн Next хопын хаяг, administrative distance болон хэдэн секундын дараа аль хаягаас шинэчлэлийн мэдээлэл ирэхийг харуулж байдаг.

Routing Information Protocol Version 2[засварлах | edit source]

RIP version 2 тухай[засварлах | edit source]

1994 онд RIPv2 буюу RFC2453,1997 онд IPv6 зориулсан RIPng буюу RFC2080 гэсэн хувилбарууд нь бий болжээ. RIPv1-тэй адил UDP сегментийг ашиглан 520– р портоор дамжуулалтыг хийдэг бөгөөд хамгийн ихдээ 15 рутер дамжих боломжтой байдаг. Мэдээний хэлбэр нь RIPv1- тэй ижил боловч дээрээс нь 2 чухал ач холбогдолтой талбар нэмэгдэн ордог.

Протоколын онцлог:
Тогтмол хугацааны шинэчлэлтийн мэдээлэл
Хамгийн ихдээ 15 хопыг дамжсан замыг бүртгэх боломжтой.
Classless,distance vector(dv) замчлалын протокол
Зөвхөн хопыг тоолдог бөгөөд түүгээрээ замчлалыг сонгодог

Протоколын ашигладаг хугацаа[засварлах | edit source]

  • Priodic update – 30 сек
  • Invalid – Шинэчлэлийн мэдээлэл ирэхгүй бол хүлээх хугацаа. Default-аараа 180 секунд байх бөгөөд энэ хугацаа дуусвал тухайн замыг infinity буюу 16 гэж үнэлнэ.
  • Holddown – энэ нь default-аараа 180 секунд
  • Flush – энэ хугацаа нь default-аараа invalid хугацаанаас 60 секундээр илүү байна(240 сек). Энэ хугацаа дуусахад шинэчлэл ирэхгүй бол тухайн замыг шууд замчлалын хүснэгтээс устгана.

Протоколын ашигладаг хаягууд[засварлах | edit source]

  • Port address - 520
  • Protocol – 17 (UDP)
  • IP address – 224.0.0.9
  • MAC address 01:00:5E:00:00:09

Протоколын мэдээний төрлүүд[засварлах | edit source]

  • Request (1)
  • Response (2)

Протоколын ашигладаг хүснэгтийн мэдээллүүд[засварлах | edit source]

  • Замчлалын хүснэгт/routing table
  • Best routes

Мэдээний формат[засварлах | edit source]

rip version 1 нь version 2-той ижил боловч version 2 нь 2 талбараар өөр байдаг.(зураг 2.1)

Зураг 2.1 Rip v1,2 мэдээний формат харьцуулалт
  • Эхний талбар бол subnet mask– ийн талбар бөгөөд 32 битийн урттай байна.
  • Дараагийн талбар бол Next хопын хаягийн талбар юм. Үүгээр хамгийн сайн next hop – ийг олох боловч ганц бол түүний хаягийг авдаг. Бүгд 0.0.0.0 бол дамжуулагч рутерийн хамгийн сайн Next hop хаяг болно.

Rip version 2 ажиллагаа болон тохиргоо[засварлах | edit source]

rip ажиллагаа: зураг 2.2 харна уу

Rip тохиргоо:RIPv2 – ийг ажиллуулахын тулд RIP тохиргооны горим дээр version гэсэн командын тусламжтайгаар гүйцэтгэнэ.Ингэснээр бүх шинэчлэлийн мэдээлэл subnet маскийг агуулна. RIPv2 – ийг тохируулсан рутер зөвхөн RIPv2 шинэчлэлийн мэдээллийг л хүлээн авах болон дамжуулдаг. Мөн RIPv1 дээр version командыг ашигласан бол дээрхтэй ижил байх ба version команд ашиглаагүй үед RIPv1 болон RIPv2 мэдээллийг хүлээн авч ойлгох боловч RIPv2 мэдээллийг нь тэр зуур устгадаг. Default-аар RIPv2 нь мөн RIPv1 – тэй адил хаягийг товчлох буюу classful хэлбэрт шилжүүлдэг. Үүнийг болиулахын тулд auto-summary – г идэвхигүй болгож өгдөг ба ингэснээр classless хаягчлалыг ашиглах боломжтой болдог.Зураг 2.3,2.4,2.5-аас харна уу
Router(config-router)#no auto-summary
Зураг 2.3 жишээ топологи
зураг 2.4 rip v2 команд
Зураг 2.5 auto summary тохируулах болон тохиргооны үр дүнг харах
Төхөөрөмж Команд
R1 R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#net 192.168.1.0
R1(config-router)#net 192.168.2.0
R1(config-router)#no auto-summary
R2 R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#net 192.168.2.0
R2(config-router)#net 192.168.3.0
R2(config-router)#net 192.168.5.0
R2(config-router)#no auto-summary
R3 R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#net 192.168.3.0
R3(config-router)#net 192.168.4.0
R3(config-router)#no auto-summary

Тохиргоо болон ажиллагааг харах, шалгах[засварлах | edit source]

тохиргоо шалгах команд
router#show ip route // замчлалын хүснэгтийг харах
router#show ip protocols // ямар протокол тохируулсаныг харах
router#debug ip rip // rip протоколын ажиллагааг шалгах
router#show ip interface brief // ямар интерфейс дээр ip хаяг тохируулсан болон up,down алин дээр байгаар харах
Зураг 2.7 Show ip procols команд
Зураг 2.8 Debug ip команд

RIP version 1,2 ялгаа[засварлах | edit source]

RIP version 1 RIP version 2
Classful сүлжээнд ажилладаг. Classless сүлжээнд ажилладаг
VLSM-г дэмждэггүй VLSM дэмжин ажилладаг.
Routing update нь броадкаст дамжигддаг. Routing update нь multicast (224.0.0.9 vs. 255.255.255.255)
routing update мэдээндээ сабнетын мэдээлэл дамжуулахгүй Update-дээ дараагийн алхмын тоог(NHA)дамжуулдаг.
authentication механизмгүй Authentication механизмтай.

RIP version 1,2 адил тал[засварлах | edit source]

version 1,2
Auto Summarizes by default
distance vector routing protocol
Хопыг тоолоод 15 дээш болбол тухайн сүлжээг unreachable буюу дамжуулалт байхгүй гэж үздэг



Дэлгэрүүлэн судлах холбоос[засварлах | edit source]

  1. Cisco IOS IP Configuration Guide, Release 12.2 ,Configuring routing information protocol
  2. rip, How to configure RIP Routing information protocol
  3. RFC1058,Routing Information Protocol, C. Hendrik, The Internet Society (June 1988)
  4. rip v1,2, CCNA2 routing information protocol version 1,2
  5. RFC2082,RIP-2 MD5 Authentication, F. Baker, R. Atkinson, The Internet Society (January 1997)
  6. RFC2080,RIPng for IPv6, G. Malkin, R. Minnear, The Internet Society (January 1997)

Ашигласан материал[засварлах | edit source]

ccnp-configure-verify-and-troubleshoot-ripv2
CCNA-2 rip version 1,2

|}