Enhanced Interior Gateway Routing Protocol

Чөлөөт нэвтэрхий толь — Википедиагаас
Jump to navigation Jump to search

Enhanced Interior Gateway Routing протокол нь Cisco компаний өмч бөгөөд анхны хувилбар нь 1985 онд IGRP нэртэй гарч байсан. 1992 онд EIGRP протокол гарсан.

EIGRP for IPv4[засварлах | edit source]

Үүсэл[засварлах | edit source]

Энэхүү протокол нь Cisco компаний өмч бөгөөд анхны хувилбар нь 1985 онд IGRP нэртэй гарч байсан. 1992 онд EIGRP протокол гарсан.

Онол[засварлах | edit source]

Enhanced Interior Gateway Routing Protocol (EIGRP) Cisco-гоос хөгжүүлсэн ба IPv4 хаяглалтай сүлжээний замчлалыг хийх зорилготой distance vector замчлалын протокол юм. EIGRP протоколыг зөвхөн сискогийн төхөөрөмжүүд дэмждэг байсан бол 2013 оноос бүх үйлдвэрлэгчдийн төхөөрөмж дэмждэг болсон. EIGRP нь distance vector замчлалын протокол бөгөөд link-state замчлалын протоколын зарим шинж чанарыг агуулсан.

  • Reliable transport protocol
  • Bounded update
  • Diffusing Update Algorithm ( DUAL )
  • Establishing adjencencies
  • Neighbor and Topology tables

EIGRP нь IGRP (Interior Gateway Routing Protocol)-оос боловсронгуй болсон. EIGRP нь зөвхөн Интернет Протоколт (IP) сүлжээнд биш, мөн түүнчлэн AppleTalk ба Novell NetWare сүлжээнд хэрэглэгдэж чадна .

Diffusing Update Algorithm[засварлах | edit source]

EIGRP замчлалын протокол нь DUAL алгоритмыг ашигладаг. EIGRP нь DUAL алгоритмыг ашиглан хүлээн авах сүлжээ хүртэлх нөөц замын мэдээллийг хадгалдаг ба шаардлагатай үед маш хурдан нөөц замаар өгөгдлийг дамжуулж эхэлдэг.

DUAL алгоритм нь үүрэг

  • Хөршүүдийг илрүүлэх
  • Routing loop байхгүй замыг олж сонгох (Successor болон feasible Successor-ийн тусламжтай)
  • Convergence-ийг хурдан болгох
  • Bounded Update-ийг ашиглах : RIP шиг тогтмол хугацаанд update мессежийг илгээхгүй.Харин шинээр холболт нэмэгдэх юмуу холболт тасархад л энэ өөрчлөлтийг мэдээлсэн update мессежийг дамжуулна.

Пакет дамжуулах болон илгээхдээ Reliable Transport Protocol(RTP) протоколыг ашигладаг. EIGRPv6 нь зөвхөн сүлжээний түвшинд ашигладаг замчлалын протокол учраас дамжууллын түвшний TCP болон UDP протоколыг ашиглаж чаддаггүй. Сүлжээний ачаалыг тэнцвэржүүлэхийн тулд unequal болон equal load balancing хэрэгжүүлдэг.

EIGRP ажиллагаа[засварлах | edit source]

EIGRP ажиллагаа

EIGRP хаягууд[засварлах | edit source]

  • Протоколын дугаар 88
  • Ашиглах IP хаяг 224.0.0.10
  • MAC хаяг 01:00:5E:00:00:0A

EIGRP мэдээний төрөл[засварлах | edit source]

  • Hello (5)
  • Reply (4)
  • Query (3)
  • ACK (2)
  • Update (1)
EIGRP мэдээний төрөл

EIGRP метрик[засварлах | edit source]

  • Зурвасын өргөн - Bandwidth
  • Саатал - Delay
  • Ачаалал - Load
  • Найдваржилт - Reliability
  • MTU

Metric = 256*((k1*BW + (k2*BW/256-LOAD)+K3*DELAY)*(k5/REL=K4))

EIGRP нь дефаултаараа зурвасын өргөн болон саатал 2ыг ашиглан замчлалаа тодорхойлдог.

Default EIGRP metric = (Bandwidth + Delay) * 256

            BW = 10000000/interfaces low bandwidth (kbps)

            Delay = SUM (interfaces Delay)/10 (µsec)

EIGRP хугацаа[засварлах | edit source]

Өөрчлөлтийн шинэчлэлтийн мэдээлэл буюу Bounded update – ийг ашигладаг.

  • Hello – 5 сек, 60 cек (T1 or slower)
  • Hold time – 15 сек, 180 сек . 

EIGRP хүснэгтүүд[засварлах | edit source]

  • Хөршийн хүснэгт
  • Топологийн хүснэгт
    • Successors – илгээгчээс хүлээн авах сүлжээ хүртэл хамгийн бага метриктэй хөрш router.
    • Feasible successors - илгээгчээс хүлээн авах сүлжээ хүртэл 2 дагч хамгийн бага метриктэй хөрш router.
  • Замчлалын хүснэгт - Successors (Best routes) сүлжээ байна

EIGRP Administrative Distance (AD)[засварлах | edit source]

  • EIGRP summary route – 5
  • Internal EIGRP – 90
  • External EIGRP – 170

EIGRP тохиргоо[засварлах | edit source]

R1(config)#router eigrp autonomous-system-number EIGRP протоколийн ажиллагааг идэвхижүүлэх
R1(config-router)#network [network address] Холбоотой байгаа сүлжээгээ бүртгэхдээ classfull хаяглалаар бүртгэнэ
R1(config-router)#network [network address] [wild mask] Холбоотой байгаа сүлжээгээ бүртгэхдээ classless хаяглалаар бүртгэнэ
R1(config-router)#network [network address] [subnet mask] Холбоотой байгаа сүлжээгээ бүртгэхдээ classless хаяглалаар бүртгэнэ. Рутерийн OS – гээс хамааран subnet mask – тай бичнэ
R1(config-router)#no auto summary Автоматаар сүлжээг нэгтгэхийг зогсооно

Нэмэлт тохиргоо[засварлах | edit source]

R1(config-if)#bandwidth [kilobits] Замын үнэлгээг өөрчлөхөд ашиглана
R1(config-router)#redistribute [протокол|process ID] metric [bandwidth] [delay] [rel] [load] [MTU] Ондоо замчлалын протоколыг өөрийн замчлалдаа оруулах
R1(config-if)#ip bandwidth-percent eigrp [as-number] [percent] Зурвасын өргөний хэдэн хувийг ашиглахыг тодорхойлно. Дефаултаараа 50% - ийг ашигладаг.
R1(config-if)#ip hello-interval eigrp [as-number] [seconds] Hello мэдээг хүлээн авах хугацааг тохируулна
R1(config-if)#ip hold-time eigrp [as-number] [seconds] Hello мэдээ ирэхгүй бол хөршийг байхгүй гэж зарлахаас түр хүлээх хугацааг тохируулна
R1(config-if)#ip summary-address eigrp [as number] [summary address] [mask] Сүлжээг нэгтгэх
R1(config-router)# passive-interface ….. Update мэдээ дамжих шаардлагагүй интерфэйсийг идэвхигүй болгох
R1(config-router)# variance [value] Load balancing (ачаалал тэнцвэржүүлэх) хийх
R1(config-router)#maximum-paths [path number] Олон сайн замыг тодорхойлох

EIGRP тохиргоог шалгах командууд[засварлах | edit source]

R1# show ip route Замчлалын хүснэгт харуулна
R1# show ip route eigrp Зөвхөн EIGRP замчлалын мэдээллийг харуулна
R1# show ip eigrp interfaces EIGRP замчлалд ашиглагдаж байгаа интерфэйсийн мэдээлэлийг харуулна
R1# show ip eigrp neighbors Хөршийн мэдээллийг дэлгэцэнд харуулна
R1# show ip eigrp topology Successor болон feasible successor сүлжээний мэдээлэл байна
R1#show ip eigrp traffic Хөрш рутерээс хүлээн авах болон дамжуулж байгаа мэдээг харна
R1# show ip protocols Ямар замчлалын прокол ашиглаж байгаа мэдээлэл байна
R1# debug eigrp … Ажиллагааг шалгаж байна

EIGRP for IPv6[засварлах | edit source]

Онол[засварлах | edit source]

Enhanced Interior Gateway Routing Protocol for IPv6 (EIGRPv6) Cisco-гоос хөгжүүлсэн ба IPv6 хаяглалтай сүлжээний замчлалыг хийх зорилготой distance vector замчлалын протокол юм. EIGRPv6 протоколыг зөвхөн сискогийн төхөөрөмжүүд дэмждэг байсан бол 2013 оноос бүх үйлдвэрлэгчдийн төхөөрөмж дэмждэг болсон. EIGRP нь distance vector замчлалын протокол бөгөөд link-state замчлалын протоколын зарим шинж чанарыг агуулсан.

  • Reliable transport protocol
  • Bounded update
  • Diffusing Update Algorithm ( DUAL )
  • Establishing adjencencies
  • Neighbor and Topology tables

EIGRP нь IGRP (Interior Gateway Routing Protocol)-оос боловсронгуй болсон. EIGRP нь зөвхөн Интернет Протоколт (IP) сүлжээнд биш, мөн түүнчлэн AppleTalk ба Novell NetWare сүлжээнд хэрэглэгдэж чадна .

Diffusing Update Algorithm[засварлах | edit source]

EIGRPv6 замчлалын протокол нь DUAL алгоритмыг ашигладаг. EIGRPv6 нь DUAL алгоритмыг ашиглан хүлээн авах сүлжээ хүртэлх нөөц замын мэдээллийг хадгалдаг ба шаардлагатай үед маш хурдан нөөц замаар өгөгдлийг дамжуулж эхэлдэг.

DUAL алгоритм нь үүрэг

  • Хөршүүдийг илрүүлэх
  • Routing loop байхгүй замыг олж сонгох (Successor болон feasible Successor-ийн тусламжтай)
  • Convergence-ийг хурдан болгох
  • Bounded Update-ийг ашиглах : RIP шиг тогтмол хугацаанд update мессежийг илгээхгүй.Харин шинээр холболт нэмэгдэх юмуу холболт тасархад л энэ өөрчлөлтийг мэдээлсэн update мессежийг дамжуулна.

Пакет дамжуулах болон илгээхдээ Reliable Transport Protocol(RTP) протоколыг ашигладаг. EIGRPv6 нь зөвхөн сүлжээний түвшинд ашигладаг замчлалын протокол учраас дамжууллын түвшний TCP болон UDP протоколыг ашиглаж чаддаггүй. Сүлжээний ачаалыг тэнцвэржүүлэхийн тулд unequal болон equal load balancing хэрэгжүүлдэг.

EIGRPv6 хаягууд[засварлах | edit source]

  • Протоколын дугаар 88
  • Ашиглах IPv6 хаяг FF02::A
  • MAC хаяг 01:00:5E:00:00:0A

EIGRPv6 мэдээний төрөл[засварлах | edit source]

  • Hello (5)
  • Reply (4)
  • Query (3)
  • ACK (2)
  • Update (1)

EIGRPv6 метрик[засварлах | edit source]

  • Зурвасын өргөн - Bandwidth
  • Саатал - Delay
  • Ачаалал - Load
  • Найдваржилт - Reliability
  • MTU

Metric = 256*((k1*BW + (k2*BW/256-LOAD)+K3*DELAY)*(k5/REL=K4))

EIGRPv6 нь дефаултаараа зурвасын өргөн болон саатал 2ыг ашиглан замчлалаа тодорхойлдог.

Default EIGRP metric = (Bandwidth + Delay) * 256

            BW = 10000000/interfaces low bandwidth (kbps)

            Delay = SUM (interfaces Delay)/10 (µsec)

EIGRPv6 хугацаа[засварлах | edit source]

Өөрчлөлтийн шинэчлэлтийн мэдээлэл буюу Bounded update – ийг ашигладаг.

  • Hello – 5 сек, 60 cек (T1 or slower)
  • Hold time – 15 сек, 180 сек . 

EIGRPv6 хүснэгтүүд[засварлах | edit source]

  • Хөршийн хүснэгт
  • Топологийн хүснэгт
    • Successors – илгээгчээс хүлээн авах сүлжээ хүртэл хамгийн бага метриктэй хөрш router.
    • Feasible successors - илгээгчээс хүлээн авах сүлжээ хүртэл 2 дагч хамгийн бага метриктэй хөрш router.
  • Замчлалын хүснэгт - Successors (Best routes) сүлжээ байна

EIGRPv6 Administrative Distance (AD)[засварлах | edit source]

  • EIGRPv6 summary route – 5
  • Internal EIGRPv6 – 90
  • External EIGRPv6 – 170

EIGRPv6 тохиргоо[засварлах | edit source]

R1(config)#ipv6 unicast-routing IPv6 замчлалыг идэвхижүүлэх
R1(config)#ipv6 router eigrp autonomous-system-number EIGRPv6 протоколийн ажиллагааг идэвхижүүлэх
R1(config-rtr)#router-id router-id router-id – ийг тохируулах
R1(config-rtr)#no shutdown EIGRPv6-н замчлалын процессыг идэвхжүүлнэ
R1(config-if)# ipv6 eigrp autonomous-system-number Интерфэйсийн горимоор орж холбоотой байгаа сүлжээнүүдийг идэвхижүүлэх

Нэмэлт тохиргоо[засварлах | edit source]

R1(config-rtr)#default ….. Дефаулт тохиргоонуудыг тохируулах
R1(config-rtr)# default-metric [kilobits] Redistribute хийсэн замчлалын метрикийг тохируулах
R1(config-rtr)# distance eigrp <1-255> Дотоод замчлалын distance – ийг тохируулах
R1(config-rtr)# distribute-list prefix-list prefix-list-name Сүлжээний мэдээллийг шүүх
R1(config-rtr)# eigrp …… Eigrp тодорхойлсон командууд
R1(config-rtr)#maximum-paths <1-32> Олон сайн замыг тодорхойлох
R1(config-rtr)# metric …… Метрикийн параметрүүдийг өөрчлөх
R1(config-rtr)#neighbor neighbor-address Хөрш рөүтер тодорхойлох
R1(config-rtr)# passive-interface ….. Update мэдээ дамжих шаардлагагүй интерфэйсийг идэвхигүй болгох
R1(config-rtr)# redistribute [protocol | process ID]...... Ондоо замчлалын протоколыг өөрийн замчлалдаа оруулах
R1(config-rtr)# summary-metric X:X:X:X::X/<0-128> Summary metric – ийг тодорхойлох
R1(config-rtr)# timers active-time Топологийн хүснэгт үүсгэх хугацааг тохируулах
R1(config-rtr)# variance <1-128> Load balancing (ачаалал тэнцвэржүүлэх) хийх

EIGRPv6 тохиргоог шалгах командууд[засварлах | edit source]

R1# show ipv6 route Замчлалын хүснэгт харуулна
R1# show ipv6 route eigrp Зөвхөн EIGRPv6 замчлалын мэдээллийг харуулна
R1# show ipv6 eigrp interfaces EIGRPv6 замчлалд ашиглагдаж байгаа интерфэйсийн мэдээлэлийг харуулна
R1# show ipv6 eigrp neighbors Хөршийн мэдээллийг дэлгэцэнд харуулна
R1# show ipv6 eigrp topology Successor болон feasible successor сүлжээний мэдээлэл байна
R1# show ipv6 protocols Ямар замчлалын прокол ашиглаж байгаа мэдээлэл байна
R1# debug ipv6 eigrp Ажиллагааг шалгаж байна

EIGRPv6 тохиргооны хэсэг[засварлах | edit source]

EIGRPv6 топологи
Топологи[засварлах | edit source]
Хаягын хүснэгт[засварлах | edit source]
Төхөөрөмж Интерфэйс IPv6 хаяг Default gateway
R1 Loopback0 2001:db8:cafe:1::1/64 N/A
Serial 1/0 2001:db8:cafe:2::1/64 Fe80::1
R2 Loopback0 2001:db8:cafe:3::1/64 N/A
Serial 1/0 2001:db8:cafe:2::2/64 Fe80::2
Serial 1/1 2001:db8:cafe:4::1/64 Fe80::2
R3 Loopback0 2001:db8:cafe:5::1/64 N/A
Loopback1 2001:db8:abcd:1::1/64 N/A
Loopback2 2001:db8:abcd:2::1/64 N/A
Loopback3 2001:db8:abcd:3::1/64 N/A
Loopback4 2001:db8:abcd:4::1/64 N/A
Loopback5 2001:db8:abcd:5::1/64 N/A
Serial 1/1 2001:db8:cafe:4::2/64 Fe80::3
Serial 1/0 2001:db8:feed:1::1/64 Fe80::3
Serial 1/2 2001:db8:cafe:6::1/64 Fe80::3
ISP Serial 1/0 2001:db8:feed:1::2/64 Fe80::4
Интерфэйст хаяг олгох[засварлах | edit source]
R1 төхөөрөмж[засварлах | edit source]

interface Loopback0

no ip address

ipv6 address 2001:DB8:CAFE:1::1/64

ipv6 eigrp 1

!

interface Serial1/0

no ip address

ipv6 address FE80::1 link-local

ipv6 address 2001:DB8:CAFE:2::1/64

ipv6 eigrp 1

serial restart-delay 0

!

interface Serial1/1

no ip address

ipv6 address FE80::1 link-local

ipv6 address 2001:DB8:CAFE:6::1/64

ipv6 eigrp 1

serial restart-delay 0

!

R2 төхөөрөмж[засварлах | edit source]

interface Loopback0

no ip address

ipv6 address 2001:DB8:CAFE:3::1/64

ipv6 eigrp 1

!

interface Serial1/0

no ip address

ipv6 address FE80::2 link-local

ipv6 address 2001:DB8:CAFE:2::2/64

ipv6 eigrp 1

serial restart-delay 0

!

interface Serial1/1

no ip address

ipv6 address FE80::2 link-local

ipv6 address 2001:DB8:CAFE:4::1/64

ipv6 eigrp 1

serial restart-delay 0

!

R3 төхөөрөмж[засварлах | edit source]

interface Loopback0

no ip address

ipv6 address 2001:DB8:CAFE:5::1/64

ipv6 eigrp 1

!

interface Loopback1

no ip address

ipv6 address 2001:DB8:ABCD:1::1/64

ipv6 eigrp 1

!

interface Loopback2

no ip address

ipv6 address 2001:DB8:ABCD:2::1/64

ipv6 eigrp 1

!

interface Loopback3

no ip address

ipv6 address 2001:DB8:ABCD:3::1/64

ipv6 eigrp 1

!

interface Loopback4

no ip address

ipv6 address 2001:DB8:ABCD:4::1/64

ipv6 eigrp 1

!

interface Loopback5

no ip address

ipv6 address 2001:DB8:ABCD:5::1/64

ipv6 eigrp 1

!

interface Serial1/0

no ip address

ipv6 address FE80::3 link-local

ipv6 address 2001:DB8:FEED:1::1/64

ipv6 eigrp 1

serial restart-delay 0

!

interface Serial1/1

no ip address

ipv6 address FE80::3 link-local

ipv6 address 2001:DB8:CAFE:4::2/64

ipv6 eigrp 1

ipv6 summary-address eigrp 1 2001:DB8:ABCD::/61

serial restart-delay 0

interface Serial1/2

no ip address

ipv6 address FE80::3 link-local

ipv6 address 2001:DB8:CAFE:6::2/64

ipv6 eigrp 1

serial restart-delay 0

!

ISP төхөөрөмж[засварлах | edit source]

interface Serial1/0

no ip address

ipv6 address FE80::4 link-local

ipv6 address 2001:DB8:FEED:1::2/64

serial restart-delay 0

!

interface Loopback0

no ip address

ipv6 address 2001:DB8:AAAA:1::1/64

!

EIGRPv6 замчлал тохируулах[засварлах | edit source]
R1 төхөөрөмж[засварлах | edit source]

ipv6 unicast-routing

!

ipv6 router eigrp 1

passive-interface Loopback0

eigrp router-id 1.1.1.1

!

R2 төхөөрөмж[засварлах | edit source]

ipv6 unicast-routing

!

ipv6 router eigrp 1

passive-interface Loopback0

eigrp router-id 2.2.2.2

!

R3 төхөөрөмж[засварлах | edit source]

ipv6 unicast-routing

!

ipv6 router eigrp 1

passive-interface Loopback0

eigrp router-id 3.3.3.3

redistribute static

!

Статик замчлал тохируулах[засварлах | edit source]
R3 төхөөрөмж[засварлах | edit source]

ipv6 route ::/0 Serial1/0

ISP төхөөрөмж[засварлах | edit source]

ipv6 route 2001:DB8:ABCD::/48 Serial1/0           

ipv6 route 2001:DB8:CAFE::/48 Serial1/0

Шалгах хэсэг[засварлах | edit source]

R3 төхөөрөмж дээр шалгах коммандуудыг ашиглаж харууллаа.

show ipv6 route – R3 төхөөрөмж

ü  Ямар нэг сүлжээрүү өгөгдөл дамжихгүй бол тухайн сүлжээрүү замчлал бичигдсэн эсэхийг энэ хүснэгтээс харж болно.

ü  Тухайн сүлжээрүү өгөгдөл буруу буюу тодорхойлсноос өөр замаар явсан тохиолдолд энэ хүснэгтээс шалгаж харна.

R3#sh ipv6 route

IPv6 Routing Table - default - 24 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, la - LISP alt

lr - LISP site-registrations, ld - LISP dyn-eid, a - Application

S   ::/0 [1/0]

via Serial1/0, directly connected

D   2001:DB8:ABCD::/61 [5/128256]

via Null0, directly connected

C   2001:DB8:ABCD:1::/64 [0/0]

via Loopback1, directly connected

L   2001:DB8:ABCD:1::1/128 [0/0]

via Loopback1, receive

C   2001:DB8:ABCD:2::/64 [0/0]

via Loopback2, directly connected

L   2001:DB8:ABCD:2::1/128 [0/0]

via Loopback2, receive

C   2001:DB8:ABCD:3::/64 [0/0]

via Loopback3, directly connected

L   2001:DB8:ABCD:3::1/128 [0/0]

via Loopback3, receive

C   2001:DB8:ABCD:4::/64 [0/0]

via Loopback4, directly connected

L   2001:DB8:ABCD:4::1/128 [0/0]

via Loopback4, receive

C   2001:DB8:ABCD:5::/64 [0/0]

via Loopback5, directly connected

L   2001:DB8:ABCD:5::1/128 [0/0]

via Loopback5, receive

D   2001:DB8:CAFE:1::/64 [90/2297856]

via FE80::1, Serial1/2

D   2001:DB8:CAFE:2::/64 [90/2681856]

via FE80::2, Serial1/1

via FE80::1, Serial1/2

D   2001:DB8:CAFE:3::/64 [90/2297856]

via FE80::2, Serial1/1

C   2001:DB8:CAFE:4::/64 [0/0]

via Serial1/1, directly connected

L   2001:DB8:CAFE:4::2/128 [0/0]

via Serial1/1, receive

C   2001:DB8:CAFE:5::/64 [0/0]

via Loopback0, directly connected

L   2001:DB8:CAFE:5::1/128 [0/0]

via Loopback0, receive

C   2001:DB8:CAFE:6::/64 [0/0]

via Serial1/2, directly connected

L   2001:DB8:CAFE:6::2/128 [0/0]

via Serial1/2, receive

C   2001:DB8:FEED:1::/64 [0/0]

via Serial1/0, directly connected

L   2001:DB8:FEED:1::1/128 [0/0]

via Serial1/0, receive

L   FF00::/8 [0/0]

via Null0, receive

Энэ хүснэгтэнд тухайн сүлжээнд хүрэх сайн зам (best route) бичигддэг. L буюу рутерийн интерфэйсд олгосон хаяг, С буюу шууд холбогдсон сүлжээ, D буюу EIGRPv6 протоколоор орж ирсэн сүлжээ, S буюу static сүлжээнүүд тэмдэглэгдсэн байна. Жишээлбэл :

D   2001:DB8:CAFE:3::/64 [90/2297856]

via FE80::2, Serial1/1

2001:DB8:CAFE:3::/64 сүлжээрүү хүрэхдээ serial1/1 интерфэйсээр гарна. AD=90 metric=2297856 байна.

S   ::/0 [1/0]

via Serial1/0, directly connected

Замчлалын хүснэгтэнд бичигдээгүй бусад бүх сүлжээрүү хүрэхдээ serial1/0 интерфэйсээр гарна. AD=1 metric=0 байна.

show ipv6 route eigrp – R3 төхөөрөмж

ü  EIGRPv6 замчлалын протоколоор ямар нэг сүлжээ орж ирсэн эсэхийг шалгахдаа энэ командыг ашиглана.

R3#sh ipv6 route eigrp

IPv6 Routing Table - default - 24 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, la - LISP alt

lr - LISP site-registrations, ld - LISP dyn-eid, a - Application

D   2001:DB8:ABCD::/61 [5/128256]

via Null0, directly connected

D   2001:DB8:CAFE:1::/64 [90/2297856]

via FE80::1, Serial1/2

D   2001:DB8:CAFE:2::/64 [90/2681856]

via FE80::2, Serial1/1

via FE80::1, Serial1/2

D   2001:DB8:CAFE:3::/64 [90/2297856]

via FE80::2, Serial1/1

Энэ хүснэгтэнд зөвхөн EIGRPv6 замчлалын мэдээллээр орж ирсэн сайн зам (best route) бичигддэг.

show ipv6 eigrp interfaces – R3 төхөөрөмж

ü  EIGRPv6 замчлалын протоколоор хөршийн мэдээ болон замчлалын мэдээллүүд ирэхгүй тохиолдолд интерфэйсийг шалгана.

R3#sh ipv6 eigrp interfaces

EIGRP-IPv6 Interfaces for AS(1)

Xmit Queue   PeerQ       Mean   Pacing Time   Multicast   Pending

Interface              Peers  Un/Reliable Un/Reliable  SRTT   Un/Reliable  Flow Timer   Routes

Se1/0                    0                 0/0         0/0           0                 0/0            0           0

Se1/1                    1        0/0          0/0         460               0/16        1368           0

Se1/2                    1        0/0          0/0         461               0/16        1380           0

Lo1                      0        0/0          0/0           0                  0/0            0           0

Lo2                      0        0/0          0/0           0                  0/0            0           0

Lo3                       0        0/0          0/0           0                  0/0           0           0

Lo4                      0        0/0          0/0           0                  0/0            0           0

Lo5                      0        0/0          0/0           0                  0/0            0           0

Энэ команд нь EIGRPv6 замчлалын протоколд ашиглагдаж байгаа интерфэйсүүд харагдаж байна.

show ipv6 eigrp neighbors – R3 төхөөрөмж

ü EIGRPv6 замчлалын протокол зөв ажиллаж байвал холбоотой байгаа рутер хөрш болсон байх ёстой. Замчлалын мэдээлэлд EIGRPv6 сүлжээний мэдээлэл орж ирэхгүй бол эхлээд шалгана.

R3#sh ipv6 eigrp neighbors

EIGRP-IPv6 Neighbors for AS(1)

H   Address                 Interface              Hold Uptime   SRTT  RTO              Q         Seq

(sec)                (ms)                 Cnt      Num

1   Link-local address:     Se1/2                     6 00:15:37  461              2766   0         11

FE80::1

0   Link-local address:     Se1/1                    13 00:15:37  460             2760   0         12

FE80::2

Энэ хүснэгтэнд EIGRPv6 замчлалын протоколын шууд холбоотой хөрш рутерүүдийн мэдээлэл харагдаж байна. Жишээлбэл :

AS- ийн дугаар 1 ба FE80::1 Link-local хаягтай төхөөрөмж нь serial1/2 интерфэйсээр холбогдсон ба update мэдээ ирээгүй 15 секунд болж байна.

show ipv6 eigrp topology – R3 төхөөрөмж

ü  Тухайн сүлжээрүү өгөгдөл буруу буюу тодорхойлсноос өөр замаар явсан тохиолдолд энэ хүснэгтээс шалгаж харна.

R3#sh ipv6 eigrp topology

EIGRP-IPv6 Topology Table for AS(1)/ID(3.3.3.3)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status

P 2001:DB8:CAFE:5::/64, 1 successors, FD is 128256

via Connected, Loopback0

P 2001:DB8:ABCD::/61, 1 successors, FD is 128256

via Summary (128256/0), Null0

P 2001:DB8:ABCD:1::/64, 1 successors, FD is 128256

via Connected, Loopback1

P 2001:DB8:ABCD:2::/64, 1 successors, FD is 128256

via Connected, Loopback2

P 2001:DB8:CAFE:3::/64, 1 successors, FD is 2297856

via FE80::2 (2297856/128256), Serial1/1

P 2001:DB8:CAFE:4::/64, 1 successors, FD is 2169856

via Connected, Serial1/1

P 2001:DB8:CAFE:2::/64, 2 successors, FD is 2681856

via FE80::1 (2681856/2169856), Serial1/2

via FE80::2 (2681856/2169856), Serial1/1

P 2001:DB8:ABCD:3::/64, 1 successors, FD is 128256

via Connected, Loopback3

P ::/0, 1 successors, FD is 256

via Rstatic (256/0)

P 2001:DB8:ABCD:5::/64, 1 successors, FD is 128256

via Connected, Loopback5

P 2001:DB8:ABCD:4::/64, 1 successors, FD is 128256

via Connected, Loopback4

P 2001:DB8:CAFE:1::/64, 1 successors, FD is 2297856

via FE80::1 (2297856/128256), Serial1/2

P 2001:DB8:FEED:1::/64, 1 successors, FD is 2169856

via Connected, Serial1/0

P 2001:DB8:CAFE:6::/64, 1 successors, FD is 2169856

via Connected, Serial1/2

Энэ хүснэгтэнд тухайн сүлжээнд хүрэх сайн зам (successors) болон нөөц (feasible successors) сүлжээнүүд бичигддэг. R1 төхөөрөмжийн router-id 1.1.1.1 байна. Жишээлбэл :

P 2001:DB8:CAFE:3::/64, 1 successors, FD is 2297856

via FE80::2 (2297856/128256), Serial1/1

2001:DB8:CAFE:3::/64 сүлжээрүү хүрэх нэг сайн зам байна. Энэ сүлжээрүү хүрэхдээ Serial1/1 интерфэйсээр FE80::2 link-local хаягтай төхөөрөмжрүү гарна. Feasible distance нь 2297856 ба reported distance нь 128256.

show ipv6 protocols – R3 төхөөрөмж

ü Замчлалын протокол ажиллагаа буруу явагдаж байвал энэ командаар шалгаж харна.

R3#sh ipv6 protocols

IPv6 Routing Protocol is "connected"

IPv6 Routing Protocol is "application"

IPv6 Routing Protocol is "ND"

IPv6 Routing Protocol is "static"

IPv6 Routing Protocol is "eigrp 1"

EIGRP-IPv6 Protocol for AS(1)

Metric weight K1=1, K2=0, K3=1, K4=0, K5=0

NSF-aware route hold timer is 240

Router-ID: 3.3.3.3

Topology : 0 (base)

Active Timer: 3 min

Distance: internal 90 external 170

Maximum path: 16

Maximum hopcount 100

Maximum metric variance 1

Interfaces:

Serial1/0

Serial1/1

Serial1/2

Loopback1

Loopback2

Loopback3

Loopback4

Loopback5

Loopback0 (passive)

Redistribution:

Redistributing protocol static

Address Summarization:

2001:DB8:ABCD::/61 for Se1/1

Summarizing 5 components with metric 128256

Энэ команд нь ямар замчлалын протокол ашиглаж байгаа мэдээлэл байна. EIGRP-IPv6 ашиглаж байгаа ба AS=1 router-id 3.3.3.3 байна. K1 ээс K5 хүртэл метрикрийг ашиглана. Update мэдээ хүлээх хугацаа 240 секунд. Хамгийн ихдээ 16 сайн зам байж болох ба хамгийн ихдээ 100 хопыг тоолно. Serial1/0, Serial1/1, Serial1/2 ба Loopback0-5 хүртэл интерфэйсийг ашиглаж байгаа ба Loopback0 интерфэйсрүү Update мэдээ илгээхийг хориглосон байна. Static замчлалыг EIGRPv6 замчлалын протоколд redistribution хийж ашиглаж байна. 5н сүлжээг нэгтгэн 2001:DB8:ABCD::/61 хаягтай сүлжээ болгон serial1/1 рүү гаргасан.

Debug – R3 төхөөрөмж

ü  Тухайн сүлжээрүү өгөгдөл буруу буюу тодорхойлсноос өөр замаар явсан тохиолдолд энэ хүснэгтээс шалгаж харна.

ü Замчлалын мэдээлэлд EIGRPv6 сүлжээний мэдээлэл орж ирэхгүй бол шалгана.

ü Замчлалын протокол ажиллагаа буруу явагдаж байвал энэ командаар шалгаж харна.

Хөрш R2 рутерийн интерфэйсийг унтраасны дараа

R3#debug ipv6 eigrp 1 neighbor

R3#

*Nov 22 20:32:59.143: EIGRP: Holdtime expired

*Nov 22 20:32:59.143: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (Serial1/1) is down: holding time expired

R3#

*Nov 22 20:32:59.147: Going down: Peer FE80::2 total=1 stub 0, iidb-stub=0 iid-all=0

*Nov 22 20:32:59.147: EIGRP: Handle deallocation failure [0]

*Nov 22 20:32:59.183: EIGRP: Neighbor FE80::2 went down on Serial1/1

R3#

*Nov 22 20:33:08.215: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state

Хөрш R2 рутерийн интерфэйсийг буцаан асаасны дараа

R3#

*Nov 22 20:33:38.211: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up

R3#

*Nov 22 20:33:40.375: EIGRP: New peer FE80::2

R3#

*Nov 22 20:33:40.375: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (Serial1/1) is up: new adjacency

Энэ команд нь яг ажиллагааг харуулдаг.